Register
It is currently Wed Jan 17, 2018 11:45 pm

Medal of Honor OpenGL error *Fixed*


All times are UTC


Post new topic Reply to topic  [ 4 posts ] 
Author Message
 PostPosted: Sat Jul 16, 2005 6:08 am   
Advanced Member
User avatar

Joined: Thu Oct 14, 2004 2:42 am
Posts: 720
Location: Alafreakin'bama
My dad was so kind as to purchase me Medal of Honor: Allied Assault, which I was soon to find has a linux installer available on their website(the world is becoming a better place). Upon first attempt at running I was greeted with this:

--- Common Initialization ---
Medal of Honor Allied Assault 1.11 linux-i386 Sep 3 2004
----- FS_Startup -----
Current search path:
/home/ageros/.mohaa/main
/home/ageros/mohaa/main
/home/ageros/mohaa/main/pak6.pk3 (104 files)
/home/ageros/mohaa/main/pak5.pk3 (259 files)
/home/ageros/mohaa/main/pak4.pk3 (593 files)
/home/ageros/mohaa/main/pak3.pk3 (669 files)
/home/ageros/mohaa/main/pak2.pk3 (4722 files)
/home/ageros/mohaa/main/pak1.pk3 (772 files)
/home/ageros/mohaa/main/pak0.pk3 (11175 files)
/media/cdrom0/main

----------------------
18294 files in pk3 files
execing default.cfg
execing menu.cfg
couldn't exec newconfig.cfg
Config: unnamedsoldier.cfg
STUB: wtf in unix/linux_general_extras.c line 95.
STUB: wtf in unix/linux_general_extras.c line 101.
couldn't exec configs/unnamedsoldier.cfg
couldn't exec localized.cfg
execing autoexec.cfg
Unknown command "fov"
couldn't exec custom.cfg
You are now setup for easy mode.
----- Client Initialization -----
Called FadeSound with: 0.000000
----- Initializing Renderer ----
----- R_Init -----
...loading libGL.so: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
...loading libMesaVoodooGL.so.3.1: SDL: SDL_GL_LoadLibrary() failed! rc == (-1).
SDL_GetError() reports "Could not load OpenGL library".
failed
ASSERT: [qcommon/common.c:406] GLimp_Init() - could not load OpenGL subsystem
(fyi)
----- CL_Shutdown -----
-----------------------
Error: GLimp_Init() - could not load OpenGL subsystem

I did a little research and it told me to do this: +seta r_gldriver /usr/lib/libGL.so. My assumption is that I was suppose to add that after I have typed the command to run the program so I did: ./mohaa_lnx +seta r_gldriver /usr/lib/libGL.so To no avail.

I am running on a geforce 6600, and recently upgraded from a voodoo 4(which is why I assume I'm getting this error). Any thoughts?

_________________
Lappy: Ubuntu 7.04 and XP HE
Desktop: Ubuntu 7.04 and XP MCE


Last edited by Ageros on Sun Jul 17, 2005 6:04 pm, edited 1 time in total.

Top
 Profile  
 PostPosted: Sat Jul 16, 2005 3:56 pm   
Member
User avatar

Joined: Mon Oct 13, 2003 11:56 pm
Posts: 288
Sounds like you have an old voodoo4 opengl library kicking around somewhere...
try reinstalling the nvidia binary 3d drivers.

_________________
------------------------------
Current Main Distro:
Gentoo 64


Top
 Profile  
 PostPosted: Sat Jul 16, 2005 4:35 pm   
Advanced Member
User avatar

Joined: Thu Oct 14, 2004 2:42 am
Posts: 720
Location: Alafreakin'bama
I did, and I checked to see if that file libmesavoodoo was even on my system, and it is not. Could it maybe me some sort of system link that has gone bad since I upgraded?

_________________
Lappy: Ubuntu 7.04 and XP HE
Desktop: Ubuntu 7.04 and XP MCE


Top
 Profile  
 PostPosted: Sun Jul 17, 2005 6:04 pm   
Advanced Member
User avatar

Joined: Thu Oct 14, 2004 2:42 am
Posts: 720
Location: Alafreakin'bama
Fixed! I had to copy libGL.so.1 then rename it to libGL.so and past it back into the folder, worked like a charm.

_________________
Lappy: Ubuntu 7.04 and XP HE
Desktop: Ubuntu 7.04 and XP MCE


Top
 Profile  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron


Powered by phpBB © 2012 phpBB Group
© 2003 - 2012 USA LINUX USERS GROUP