OpenSuse fsck.ext3 maintenance mode
Page 1 of 1

Author:  Jeff.S [ Fri Mar 28, 2014 4:19 pm ]
Post subject:  OpenSuse fsck.ext3 maintenance mode

One of our guys installed the Appassure Client for SLES on Opensuse 11.3 - i586. Unfortunately, that broke something.

Fsck.ext3 throws this error on boot:

fsck.ext3: error while loading share libraries: cannot open shared object file: No
such file or directory

Fsck failes, so the system loads into maintenance mode with a read only file system.

I ran fsck on the drive, and it succeeds every time. The box is running in ESXI with a drive array, and I don't think we have a bad drive. This started with Appassure, and that is probably the problem. And no, there is no snapshot from before the install, sadly. I have one now that I am trying multiple fixes.

The instructions for removing the appassure agent have been run. The installation script may be run with "-u" to uninstall. It fails to download '/repodata/repomd.xml' several times, then takes the rpm packages out. At this point, it has been run, and running it again it says 'Nothing to do'.

Another Appassure deployment guide includes instructions for removing the Appassure components with rpm and zypper. This has worked in the past when someone decides to try to use appassure to backup this box and causes this issue, but it is not working this time. This set of commands succeed--all the rpm removals are successful. However, the "zypper remove dkms" throws some more repodata errors, and then says "Nothing to do."

There are still some errors when it boots pertaining to appassure, even in maintenance mode, namely the alias for Appassure VSS entry in /etc/sysconfig/kernel. I've commented it out, but it occurs after the fsck check and changed nothing. It does make me think Appassure did not uninstall correctly. Also, the ldd /sbin/fsck.ext3 shows that is in /opt/appassure/lib/, which it is, but that is not the original library location. There is an extra entry in, and if the opt/appassure is removed, the ldd result goes back to /lib/, but the problem does not go away.

Is this an Fsck.ext3 issue? The object not found problem would seem to indicate that, but the /lib/ is present, and linked to /lib/

I've reinstalled the rpm for util-linux. No change. I've tried to reinstall appassure, but the script won't complete without downloads or the original iso (which I don't have and can't find for opensuse 11.3 1-82 i586). I tried to upgrade to 11.3 final, but it failed on the grub configuration, and then would not boot. I rolled back to a snapshot before the 11.3 upgrade, so I am back at square one.

Is this really a grub problem somehow?

Author:  masinick [ Fri Mar 28, 2014 7:22 pm ]
Post subject:  Re: OpenSuse fsck.ext3 maintenance mode

Well, you have the most current release of SLES, which is Version 11, Service Pack 3, so that should not factor into the discussion. (On the "free" and "open" side, openSUSE 13.1 and has been developing openSUSE 13.2).

Usually when fsck generates an error it does mean that something is out of sync. From a software standpoint, it usually means that the link to a specific location is not intact, and that could mean that either the link is incorrect, the physical location is incorrect, or there are physical problems associated with either the file system link, the file system file contents, or both, and that does include the possibility of a hardware failure, the interruption of an activity, which prevents the link from matching the file location, resulting in the reference and the contents not matching. Without a doubt a hardware problem could introduce an error severe enough that the file system check could not complete.

Have you tried to do a file system repair from single user mode (mode S or mode 1)? If not, a correcting run of fsck will either correct the issue, if it can be corrected, or if it continues to occur, then at that point you cannot ignore the possibility of some bad blocks on your disk, which are not entirely uncommon, even on disks with remaining shelf life, but can be frequently symptomatic of a disk in the first phases of breakdown. I don't care if the disk is new, a disk is a hardware component, and hardware components, even those with a five to ten year shelf life can still break down; unexpected power spikes can also destroy data so do not completely rule out any of those possibilities.

A hardware disk block by block scan (which fsck can do) can tell you; if you don't trust fsck, there are other disk analysis tools that you can run off line or from a live distribution that may be able to give you additional information.

Page 1 of 1 All times are UTC
© 2000, 2002, 2005, 2007 phpBB Group •